일 | 월 | 화 | 수 | 목 | 금 | 토 |
---|---|---|---|---|---|---|
1 | 2 | 3 | 4 | 5 | 6 | 7 |
8 | 9 | 10 | 11 | 12 | 13 | 14 |
15 | 16 | 17 | 18 | 19 | 20 | 21 |
22 | 23 | 24 | 25 | 26 | 27 | 28 |
29 | 30 | 31 |
Tags
- 버프스위트
- HISTTIMEFORMAT
- pam_tally -u -r
- aws 자격증 접수 오류
- Default vpc
- 장치에 남은 공간이 없음
- svn: Can't find a temporary directory: Internal error
- histoy옵션
- rm -f
- 프리티어 비용 발생
- ln -Tfs
- CentOS-Base.repo
- root로그인안됨
- Default 삭제
- Unable to create a new virtual machine: No permission to perform this operation.
- Burp Suite
- pam_tally2.so
- 모바엑스텀 설치
- i-node full
- AWS
- uptime -s
- uptime -p
- 패키지 출력
- pam_tally -u
- AWS 시험후기
- 리눅스 telnet
- uptime -V
- burpsuite
- Default 생성
- 버프슈트
Archives
- Yesterday
- Today
- Total
코드업(CodeUp) 기초 100제(6029) - 파이썬(Python) 본문
728x90
반응형
1. 6029 : [기초-값변환] 16진 정수 입력받아 8진수로 출력하기(설명)(py)
1_1) 아래 경로로 접속합니다.
경로 : https://codeup.kr/problem.php?id=6029
문제 설명 |
16진수를 입력받아 8진수(octal)로 출력해보자. |
입력 |
16진 정수 1개가 입력된다. |
출력 |
8진수 형태로 출력한다. |
입력 예시 |
f |
출력 예시 |
17 |
내 답안 |
num1 = int(input(),16)
print('%o'%num1)
모범 답안 |
a=input()
a=int(a,16)
print("%o"%a)
참고 |
입력값을 16진수로 받기 위해서 input() 함수를 int() 함수에 넣었고 뒤에 16을 적었습니다. int(input(), 16) 8진수로 출력하기 위해서 %o를 사용했습니다. |
728x90
반응형
'Python > Python 코딩테스트' 카테고리의 다른 글
코드업(CodeUp) 기초 100제(6030) - 파이썬(Python) (1) | 2021.08.17 |
---|---|
코드업(CodeUp) 기초 100제(6028) - 파이썬(Python) (0) | 2021.08.15 |
코드업(CodeUp) 기초 100제(6027) - 파이썬(Python) (0) | 2021.08.14 |
코드업(CodeUp) 기초 100제(6026) - 파이썬(Python) (0) | 2021.08.13 |
코드업(CodeUp) 기초 100제(6025) - 파이썬(Python) (0) | 2021.08.12 |
Comments